This project is read-only.
1

Closed

Compile project against 4.0 Framework

description

High,
 
I have tried compiling a project that uses the PersistentManager.dll against the 4.0 .Net Framework but when I run it I get the following exception:
"System.Exception: Could not open Database Session ---> System.IO.FileLoadException: Mixed mode assembly is built against version 'v2.0.50727' of the runtime and cannot be loaded in the 4.0 runtime without additional configuration information."
 
Is 4.0 Framework not supported?
 
Thank you,
Ioan Agopian
Closed Mar 12, 2011 at 8:57 PM by ahmedsalako
Problem fixed. The latest Rapid release supports 4.0

comments

ahmedsalako wrote Aug 6, 2010 at 6:32 AM

This error is popular when you want to use 3.5 against 4.0, add the following to your config file.

<startup useLegacyV2RuntimeActivationPolicy="true">

Or download the source code, convert it to 4.0 and re-build.

Thanks

jonic wrote Aug 11, 2010 at 5:50 PM

Thank you - I've added the line to the config file - and it works without problems.

wrote Mar 12, 2011 at 8:57 PM

wrote Feb 13, 2013 at 6:33 PM

wrote May 15, 2013 at 2:17 AM